Simply Statements users using IE 10 or lower might receive a “Stronger security is required” message from their browser, as these versions of IE are no longer considered to be secure. You should update your browser to something more secure such as Chrome, Firefox, IE 11 or Microsoft Edge®.